[FIXED] Controller sometimes not powering up?

Hi all!
My controller sometimes does not power up completely when I power up the computer.

  • controller is plugged into trashcan mac pro directly (no hub)
  • about 50% of the time, when I power up the computer, the controller does the rainbow lights and powers up correctly
  • about 40% of the time, the controller just doesnt seem to do anything when I power up the computer, and I have to un-plug and re-plug the controller to make it power up
  • about 10% of the time, it seems to “try” and power up - by which I mean, it does a tiny bit of rainbow LED and then all the lights just go out, as opposed to the full power up cycle where the lights fade. And again, I have to un-plug and re-plug the controller to make it power and be seen by the computer.

Once its powered up, it seems to stay powered up. So it only seems to be a problem when I initially power up the computer.

1 Like

Hello @matt!

Welcome to the forum!!

Thank you very much for reporting this, we will try to reproduce it.

Just for clarifying, this doesn’t happen if you unplug and replug the controller when your computer is ON, but only when your computer is OFF and you turn it ON, am I correct?

hi - yes that’s correct
It ALWAYS works if you un-plug and re-plug the controller.
The only problem happens when the computer is OFF and you boot it up.

Have you tried this with another computer?

@matt do you have external power or is it all USB power?

I’ve experienced something similar with rebooting, but I’m using an external power supply…

this is just with USB power. I dont have a suitable PSU right now. I will try with a different computer soon


Hello @matt!

We were able to replicate the error here with a Mac Mini computer.

Apparently when you power on the machine, it gives power to the controller, but as soon as the Apple logo comes on screen, “something” really misterious happens with the usb port which freezes the controller.
I’ve been digging on the internet to find what is going on there, but hadn’t find anything yet that helps me understand what is actually happening.

That said, we found a way to make a fix here, which is detecting the controller freezing and rebooting if this happens.

This way at least you won’t have to disconnect and reconnect the controller. We tried it here and it works. When the OS loads, the controller is properly displayed.

It’s not a permanent fix, we will keep trying to understand the reason why this happens, but for now, when v0.15 of the firmware comes out, this fix will be there.

1 Like

ah thats very interesting! Thankyou for looking into it

Curious if this has been addressed in firmware yet? thankyou!

Hello @matt!

v0.15 includes the temporary fix we discussed in this thread.

Great - thankyou
I will update it now

I installed the new firmware, and the controller now seems to power up more reliably :wink: However, for some reason, Live doesnt seem to remember the controller. Each time I launch Live, I have to re-select the controller as a source. Any ideas?

@matt, try erasing the icon(s) for your controller on the Audio MIDI set up/MIDI studio and hook it up again.