Mac won't detect controller

I recently bought a controller and at first it was just plug and play. Everything worked great but then it started to lose connection to the computer every time it started up. And then, it simply didn’t even show up as a device in the midi-setup anymore and I can’t connect to it with kilowhat either.

So I took it with me and tried it on another mac and there everything worked just fine. So I’m realising this is an issue with my mac and that it’s not detecting the yaeltex-controller, but I have no idea how to solve it.

Hello @david_kuse!

The controllers are plug 'n play as you say.

What you mention happening is not usual, but I’d check in the MIDI studio in you Mac for the device AUDITORY and then delete it.

And see if it comes up again when you plug it in.


That’s exactly what I tried but it didn’t show up again. Is there anything else that might need to be deleted for it to show?

Hello David,

Sorry for the late reply on this.

I can’t think of anything else now, we can schedule a call to further investigate what’s going on.

I’ll write via email.