Store most recently used path(s) in the firmware uploader

A very very small request:

It might be nice if the firmware updater stores the most recently used paths for the Main and Aux firmware (separately) so that the load dialog went there first, instead of a default path. (I’m only on Windows, and haven’t reviewed the code, so I don’t know what it does on MacOS.)

For anyone doing firmware hacking that would save a few seconds of selecting the build directory each time (and the occasional uploading of the Aux firmware to the Main controller :stuck_out_tongue: --thanks for including the MIDI short circuit trick, it works perfectly! )



also, uh, what is the aux firmware? I’ve only ever updated the main firmware

Hi @mike and @gc3.

Your controllers have 2 different firmware files:

  • MAIN: Firmware for the main microcontroller. This one reads all the inputs and handles USB/MIDI communications.
  • AUX: Firmware for the auxiliary microcontroller that controls LEDs.

Sorry I didn’t specify this in the version release notes, but in the case of v0.14, both files need to be updated.
Eventually you’ll only need a zip file! We’re working on it, and not longer after that, you’ll be able to use Kilowhat to handle your firmware upgrades.

That’s a good idea!
In Windows, what I do, but only because I go to these folders A LOT, is that I pin the folder to the Quick Access list so I am only one click away from it, but I get that no clicks is even better :stuck_out_tongue:


okay, so… after reading this I went ahead and downloaded the 0.14 aux binary and loaded it into the controller. I tried running something on it and it was unresponsive, so I then tried reloading my version of the main firmware. still nothing, so I did the midi out-to-in trick to get it into the bootloader and loaded both the aux and the main. do they need to go in a certain order?

it’s still unresponsive. it shows up on USB, but it’s not sending or receiving any midi. even Kilowhat thinks it’s there, but when I tap the buttons, there’s no response with midi monitor enabled.

how do I go back to square 1 and start fresh?

@mike, I’ll test these binaries tomorrow and see if I can reproduce.

In the meantime: does the rainbow effect show up when you plug and unplug the USB (or cycle power, if you’re using an external supply?)

No, it was not doing the rainbow effect. I just reloaded it with the 0.13 main and aux and it’s fine again. loaded it with my modified 0.14 main and it’s back to where it was. you guys made a sturdy bootloader, fortunately :slight_smile:

1 Like

Yeah, I’ve done terrible things to the bootloader (for example, I once uploaded the GitLab HTML files because I did “Save Link As” instead of clicking through to the binary) and nothing seems to take it down. I also field-stripped an IEC power cable with a knife to get two wires when I was in a place without a MIDI cable, and that also worked. Pretty rugged stuff!

Re-reading your post–you’re using the current official 0.14 main and aux and having trouble? Or are you using a modified 0.14 and the official aux? I ask because the work @francoytx has been doing relies on modifications on both sides and I’m wondering if it’s possible that not all of those made it into the 0.14 branch you modified. Just want to make sure I’m testing what will be most useful to you.

1 Like

I downloaded both the main and aux 14 from and couldn’t get it to work. when I went back to 13, fine. and then updating with my 14-based mod (but not touching aux) works fine.

1 Like

Got it, thanks. I’m interested in the fact that your v0.14 mod seems to work with v0.13 aux–maybe the protocol change only affects v0.15. Anyway, I’ll test the v0.14 binaries ASAP.


Sorry to hear you’re having trouble @mike.

v0.14 by itself, as downloaded from the GitLab binaries folder you linked, is working for me in 3 different controllers, so I’m not being able to reproduce.

If you are using a modified version of v0.14 main, you can upload a zip with your project and I can give it a look to see if something’s missing or detect what’s failing.

It’d be great if we moved this to a different topic, as it is a separate issue than what @gc3 posted.
Maybe post a new topic in the “Help and troubleshooting” category?


1 Like

will do…