Trouble with aux firmware

As I posted elsewhere, I’ve had trouble loading the 0.14 aux firmware. I tried and the controller stopped responding. I tried a few things and was able to get it back to working by going back to 0.13.

Here’s what happened:

  • I had 0.13 aux and main loaded (actually, I maybe hadn’t updated aux since I got it)
  • I cloned 0.14 main from gitlab and made my mods; loaded it and ran fine (didn’t update aux)
  • I downloaded 0.14 aux binary from gitlab and loaded, controller was dead
  • Tried downloading and installing 0.14 main, still no good
  • Finally went back to 0.13 aux and main, that worked
  • Went back to 0.13 aux and my modified 0.14 main, that worked

When I cloned the code, I just cloned the main repo, added my changes in ytx-controller, and built from there. The main branch is 0.14 now, right? Not positive when I cloned, but I think it was after 0.14 was merged.


Like I said in the other post, I am not able to reproduce this.

Could you upload a zip file with your modified v0.13 main and v0.14 main firmwares?

This way I can check if the modifications may have altered something there or maybe if you cloned before the merge of v0.14.

Yes, correct, the dev branch has the 0.14 firmware, I am coding v0.15 in a different branch.

You want a zip of the binaries? or my modified code? (101.5 KB)
types.h (17.8 KB)

So, do you have links to up-to-date firmware for both main and aux that I can try out? And maybe detailed step-by-step instructions so I can be sure I’m not doing something wrong? if I can get it working properly with compiled firmware, then I’ll try checking out and modifying source.

Hello Mike!

There seems to be something wrong with the dev branch not being in sync with the 0.14 aux firmware.
I am testing this out trying to find what’s off.

The v0.14 main and aux in the binaries folder should work ok.

Okay, I re-downloaded 14 main and aux binaries and loaded them in (main first), and they seem to be working fine. Now, what source should I grab?

Ok I think I found it.

Please re-download the hardware folder (specifically the variant.cpp file had an issue)

Replace this folder in your Documents/Arduino/hardware and recompile.

Let me know if it works!

Ok, looks good. I cloned the repo, copied over hardware, updated with my changes, and it all seems to be working together.

I tried the test we did before and it seems to be working okay. The only consistent issue I’m seeing is that I need to put in a delay at the beginning of the program, or it misses out on the first 60 or so messages.