[SOLVED] Hello again! and trouble getting my Yaeltex working

Hello, everyone! It’s been a while, but I’m trying to get back to working on my Yaeltex, HACHI. Before I was using it as a controller for Java software running on mac/pi, but now I want to implement directly in Yaeltex firmware, after doing some experimenting with Launchpad firmware. But before that I just wanted to see it working basically with MIDI.

However, I’m having trouble getting my controller going. Here’s what’s happened:

  • Plugged it in to the computer, pushed buttons, but Ableton Live doesn’t see any midi input
  • Tried running kilowhat; it sees the device but says “Could not get device BLOCK 0 to load config”
  • Tried loading latest firmware (0.22) to it, no change
  • Tried loading 0.21
  • I think it was with 0.21, I was briefly able to see it in kilowhat and load the default settings
  • Tried using it with Live, and live received controller and note messages
  • But kept having stuck notes, after which it would no longer receive notes from the Yaeltex until I reset
  • But now it’s in a state where it seems to keep restarting (lights blink on, then go off, pause, repeat). Kilowhat sees it, then loses it, gives the BLOCK 0 message, etc. No MIDI coming in to Live

So, how do I get it out of this reboot loop? and what firmware should I put on HACHI?

1 Like

Hello @mike!

Long time no see. Welcome back!
I am sorry to hear you had trouble updating your controller’s firmware and getting it to work.

I see you tried updating to non-official releases, but did you see the update process to v0.20?
That update includes a necessary step using Kilowhat to update the configuration.
After this, update to v0.21 and v0.22 is a lot easier, and don’t require this step again.

We can schedule a call to help you restore the controller if you think you can’t solve it on your own.

Hope this info helps, let me know if I can help further.

Hello again @francoytx!

No, I did not know about v0.20, so I’m trying that. Since Hachi was in a messed up state, I went back to v16 and loaded an old configuration, then was able to follow the directions to get to v20 and then to v22. So now I’m on the latest and it’s working great as a MIDI controller. thanks!

Now… on to trying to figure out your code :smiley:

1 Like


Great to hear you could solve the issue!

Hahahahha good luck :slight_smile:
If you need help let me know